hi,你好!欢迎访问本站!登录
本站由简数采集腾讯云宝塔系统阿里云强势驱动
当前位置:首页 - 文章 - 开发工具 - 正文 君子好学,自强不息!

关于composer install出现的php版本问题_编程开发工具

2020-06-19开发工具ki4网11°c
A+ A-

sublime必掌握的基本操作(收藏)_编程开发工具

下面由sublime教程栏目给大家介绍sublime必掌握的基本操作,希望对需要的朋友有所帮助! home键:将光标移到本句开头; end键:将光标移到本句末尾;alt+shift+数字键(1,2..):分屏操作,若2则分为...

下面由composer教程栏目给大家介绍关于composer install出现的php版本问题的解决方法,希望对需要的朋友有所帮助!

problem : 执行 composer install 或 composer update 的时候,错误提示为 你的php版本号过低,不满足它的版本需求,而且在你用wamp切换到合适的版本号之后还是不可以。

ps:

1)如果你的php版本没有达到要求的,你可以去下载一个php包,安装在G:\wamp64\bin\php目录下。

2)在你之前的php文件夹中找到 php.ini phpForApache.ini wampserver.conf,复制到你新下的php文件夹中。

3)在 php.ini 和 phpForApache.ini 中修改信息如下

extension_dir ="G:/wamp64/bin/php/php7.1.9/ext/" 路径为你需要的路径,一般只需要修改版本号。

4)在 wampserver.conf 中修改信息如下(将 5 改为合适的数字,比如你现在是php7.1.9版本,就把 5 改成 7,即版本号最前面的数字。)

notepad++文本文件内容丢失该怎么办_编程开发工具

下面由notepad教程栏目给大家介绍Notepad++​文本文件内容丢失的解决方法,希望对需要的朋友有所帮助!今天用着notepad++不知道怎的,突然就崩溃了,然后我下次打开的时候弹了个框,我按了OK之后,里面所有的内容都不见了...

原来:

$phpConf['apache']['2.4']['LoadModuleName'] = 'php5_module';
$phpConf['apache']['2.4']['LoadModuleFile'] = 'php5apache2_4.dll';

改为:

$phpConf['apache']['2.4']['LoadModuleName'] = 'php7_module';
$phpConf['apache']['2.4']['LoadModuleFile'] = 'php7apache2_4.dll';

5)重启wamp

answer : 你虽然改变了wamp的版本,但是你composer在安装的时候选择的版本没有变,需要再重新装一遍composer,

composer下载地址:https://getcomposer.org/download/ ,进入页面后点击如图所示的地方。


在安装过程中会出现如图所示的地方,点击Browse,修改你的php版本,这时候你再执行composer install 或者 composer update 的时候,使用的php版本才是你所设置的。

更多composer技术文章,请访问composer栏目!

以上就是关于composer install出现的php版本问题的详细内容,更多请关注ki4网其它相关文章!

VSCode 如何全部替换?_编程开发工具

VSCode全部替换的方法:首先依次按下【Ctrl键】+【H键】;然后在第1个输入框中输入被替换的内容,第2个输入框输入替换内容;最后按下【Ctrl键】+【Alt键】+【Enter键】即可实现全部替换。

  选择打赏方式
微信赞助

打赏

QQ钱包

打赏

支付宝赞助

打赏

  选择分享方式
  移步手机端
关于composer install出现的php版本问题_编程开发工具

1、打开你手机的二维码扫描APP
2、扫描左则的二维码
3、点击扫描获得的网址
4、可以在手机端阅读此文章

发表评论

选填

必填

必填

选填

请拖动滑块解锁
>>